Back
Maintenance

Feature Release - Downtime
Completed 24 Feb at 06:30am AEDT.
pplusi.purchaseplus.com
V2 API - api.purchaseplus.com
purchaseplus.com/heartbeat
Completed
Maintenance completed
Posted
24 Feb at 06:30am AEDT.

Started
We will be undergoing a feature release with downtime during this time.
Posted
24 Feb at 06:00am AEDT.