Get in touch
Back
Maintenance

Scheduled maintenance

Completed 20 Jun at 10:30pm AEST.

pplusi.purchaseplus.com
Completed

Maintenance completed

Posted 20 Jun at 10:30pm AEST.
Updated

Maintenance is complete, P+i will be back online shortly.

Posted 20 Jun at 09:32pm AEST.
Started

We’re carrying out important database maintenance and P+i will be temporarily unavailable from approximately 8:30PM to 10:30PM AEST. We appreciate your patience and understanding.

Posted 20 Jun at 08:30pm AEST.